Login | Register
My pages Projects Community openCollabNet

Discussions > discuss > Problem starting ArgoUML

issuetrack
Discussion topic

Back to topic list

Problem starting ArgoUML

Reply

Author "Gautam, Ajay" <AGautam at ets dot org>
Full name "Gautam, Ajay" <AGautam at ets dot org>
Date 2001-12-07 13:05:11 PST
Message Hello,

I downloaded ArgoUML for Linux from http://argouml.tigris.org , clicked on
the downloads tab, selected the following file.

ArgoUML-0.9.5.tar.gz

I unzip, untarred copied all jars

====================​====================​
/usr/local $ ls -l ArgoUML
total 4352
-rw-r--r-- 1 root root 310567 Oct 15 09:57 antlrall.jar
-rw-r--r-- 1 root root 1566784 Oct 15 10:08 argouml.jar
-rw-r--r-- 1 root root 393055 Oct 15 09:57 gef.jar
-rwxr--r-- 1 root root 158892 Oct 18 10:42 log4j.jar
-rw-r--r-- 1 root root 500428 Oct 15 09:57 nsuml.jar
-rw-r--r-- 1 root root 676985 Oct 15 09:57 ocl-argo.jar
-rw-r--r-- 1 root root 988 Oct 15 09:57 README.txt
-rw-r--r-- 1 root root 804460 Oct 15 09:57 xerces.jar

====================​====================​

I created a run script:

====================​====================​
/usr/local/bin $ cat argouml
ARGODIR=/usr/local/ArgoUML
ARGOJARS=${ARGODIR}​/antlrall.jar:${ARG​ODIR}/argouml.jar:$​{ARGODIR}/gef.jar:$​
{ARGODIR}/log4j.jar:​${ARGODIR}/nsuml.ja​r:${ARGODI
R}/ocl-argo.jar:${A​RGODIR}/xerces.jar

if [ ${CLASSPATH}x != x ]
then
        CLASSPATH="${CLASSPATH}:"
fi

CLASSPATH=${CLASSPA​TH}${ARGOJARS}
echo $CLASSPATH
java -jar argouml.jar
====================​====================​

when I run argouml script, I get:

====================​====================​
/home/agautam $ argouml
/usr/local/ArgoUML/a​ntlrall.jar:/usr/loc​al/ArgoUML/argouml.j​ar:/usr/local/Ar
goUML/gef.jar:/usr/l​ocal/ArgoUML/log4j.j​ar:/usr/local/ArgoUM​L/nsuml.jar:/usr
/local/ArgoUML/ocl-a​rgo.jar:/usr/local/A​rgoUML/xerces.jar
Exception in thread "main" java.util.zip.ZipException: No such file or
directory
        at java.util.zip.ZipFil​e.open(Native Method)
        at java.util.zip.ZipFil​e.<init>(ZipFi​le.java:115)
        at java.util.jar.JarFil​e.<init>(JarFi​le.java:120)
        at java.util.jar.JarFil​e.<init>(JarFi​le.java:58)
====================​====================​

Relevant info:

- Java version:
====================​====================​
java version "1.4.0-beta3"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.0-beta3-b84)
Java HotSpot(TM) Client VM (build 1.4.0-beta3-b84, mixed mode)
====================​====================​
- JAVA_HOME=/usr/java/j2sdk1.4.0
- JAVA_HOME/bin is in path
- System: Redhat Linux 7.2

Any Ideas, whats happening ? I tried to find a solution on the net and your
website, could not find anything. Please help !

Ajay




********************​********************​********************​**************
This e-mail and any files transmitted with it may contain privileged or
confidential information. It is solely for use by the individual for whom
it is intended, even if addressed incorrectly. If you received this e-mail
in error, please notify the sender; do not disclose, copy, distribute, or
take any action in reliance on the contents of this information; and delete
it from your system. Any other use of this e-mail is prohibited. Thank you
for your compliance.




--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: discuss-unsubscribe@​issuetrack.tigris.or​g
For additional commands, e-mail: discuss-help@issuetr​ack.tigris.org

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

Problem starting ArgoUML "Gautam, Ajay" <AGautam at ets dot org> "Gautam, Ajay" <AGautam at ets dot org> 2001-12-07 13:05:11 PST
Messages per page: